Plattentausch/-erweiterung bei einem Synology High Availability (SHA)

Es fing damit an, dass nach etwas über 3 Jahren die erste Platte in meinem HA-System aus 2 DS716+ fehlerhafte Sektoren anmeckert. Bei meiner Suche nach dem richtigen Vorgehen gleich alle Platten zu ersetzen, bin ich leider nicht fündig geworden.

Mein Plan war nicht nur die defekte Platte, sondern gleich alle zu tauschen und gleich zu erweitern. Nach einem kurzen Mailverkehr mit dem Support wusste ich jetzt zwar, dass man immer paarweise vom aktiven und passiven Server tauschen soll, aber noch nicht womit ich anfange.

So im Nachhinein ist es eigentlich total logisch, aber vielleicht hilft der Beitrag ja doch dem ein oder anderen, der es auch zum ersten Mal in Angriff nimmt.

Meine Überlegung war dann noch: Wenn der aktive zuerst seine Platte verliert, dann schwenkt ja das System, also ist die logische Konsequenz mit der passiven Seite zu beginnen.

Da im aktiven Server die Platte 2 defekt war ging ich also wie folgt vor.

  • HDD2 im passiven Server raus.
  • Kurz warten bis das System das mitbekommt und Alarm schlägt.
  • Im HA-Manager über die Weboberfläche den Signalton abstellen, die Status-LED am System blinkt dann weiter schnell rot.
  • Die neue HDD in Schacht 2 einbauen und kurz warten ob sie anläuft.
  • HDD2 im aktiven Server raus.
  • Kurz warten bis das System das mitbekommt und Alarm schlägt.
  • Im HA-Manager über die Weboberfläche den Signalton abstellen, die Status-LED am System blinkt dann weiter schnell rot.
  • Die neue HDD in Schacht 2 einbauen und kurz warten ob sie anläuft.
  • Im HA-Manager unter Speicher/HDD prüfen ob beiden Platten erkannt wurden.
  • Dann sollte im HA-Manager unter Speicher/Volumen bei dem Volume zudem die Platten gehörte stehen, dass es defekt ist. Hier sollte nun der Button „Reparieren“ aktiv sein. Diesen drücken und darauf achten, dass einem das System auch vorschlägt das Volumen im aktiven Server zu reparieren.
  • Nach Bestätigung war nach ca. 13h das Volumen im aktiven Server wieder im Sync. Ich wollte das ganze für den passiven Server dann wiederholen, aber der Vorgang hatte sich schon selbst gestartet.
  • Nach weiteren 13h war dann alles wieder „grün“ und ich habe den Vorgang mit HDD1 wiederholt.

Man muss sich also relativ viel Zeit mitbringen, aber bisher gab es keine Ausfallzeiten. Das System ist gerade bei ca. 90% vom Sync des aktiven Servers. Ich hoffe, dass morgen Vormittag alles durch ist und ich dann um Speichermanager das Volume vergrößern kann.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Durch die weitere Nutzung der Seite stimmst du der Verwendung von Cookies zu. Weitere Informationen

Die Cookie-Einstellungen auf dieser Website sind auf "Cookies zulassen" eingestellt, um das beste Surferlebnis zu ermöglichen. Wenn du diese Website ohne Änderung der Cookie-Einstellungen verwendest oder auf "Akzeptieren" klickst, erklärst du sich damit einverstanden.

Schließen