3CX in VM der Strato-Server-Cloud installieren

Vorgeschichte

Ich habe anhand der Anleitung versucht auf der Strato-Server-Cloud 3CX als ISO Image zu installieren, leider ohne Erfolg. Bei dem Installations-Vorgang bekam der Server zwar per DHCP seine von Strato zugewiesene IP-Adresse aber es wurde kein default Gateway hinterlegt, was dann dazu führte, dass die Installation mit der Fehlermeldung stehen blieb:

Failed to retrieve the preconfiguration file.

Nachdem ich dann auf die Shell ging, war schnell klar – das System hat keinen Internetzugriff. Warum, konnte ich nicht herausbekommen, weil man über das Cloud-Panel nicht sonderlich viel von der VM-Ware einsehen kann. Der manuelle Versuch das GW zu hinterlegen, welches die anderen VMs automatisch bekommen haben, schlug mit dem Fehler „SIOCARDDRT: Network is unreachable“ fehl.

Lösung

Als ich schon am Aufgeben war und alles an VMs und Images bei Strato wieder gelöscht hatte, um für die Resourcen keine Kosten zu generieren, startete ich noch einen Versuch. Ich wollte ausprobieren ob das ISO-File vielleicht das Problem ist und habe es auf dem MAC in einer lokalen VMWare (MAC Fusion) gestartet. Hier lief der Installer soweit durch, das man zu dem in der Anleitung beschriebenen Assistenten kam.

Danach habe ich die VM dann heruntergefahren und wollte dieses Image nun bei Strato hochladen. Jetzt war die Frage, wie bekomme ich das dort geforderte Format aus der VM? Strato lässt hier folgende zu: Gültige Dateitypen sind .vdi, .qcow, .qcow2, .vhd, .vhdx and .vmdk.

Image für Strato „erzeugen“

In VMWare gibt es den Punkt Exportieren – darüber habe ich das Format OVA ausgewählt, was alles in eine Datei exportiert. Diese Datei habe ich dann mit:

tar xvf imagename.ova

in einen Ordner entpackt. Dabei gab es dann eine Datei mit dem Namen (hängt vom Namen der VM ab): „3cx-disk1.vmdk“ welche bei Strato als Image importiert werden konnte.

Wieder kein Internet

Das Image startete dann, aber in dem Assistenten stand für die weitere Installation, man solle auf http://localhost:5015?v=2 gehen – was mich schon sehr wunderte. Also neu gestartet und im Bootmenü über die KVM-Konsole das Rettungssystem gebootet. Hier war dann schnell zu sehen, wieso das Ganze nicht ging. Es gab kein Interface – aber wieso?

ifup ens192 (so wie es auf anderen VMs heißt) brachte nur den Fehler: „Interface not found“. Hmmm – ein Blick in die Datei: /etc/network/interfaces brachte dann die Erleuchtung. Dort stand ens32 (so ist wohl der Name in der VM Fusion Installation gewesen). Also alle stellen von ens32 in ens192 geändert und ein ifup ens192 gemacht – TATA IP, GW alles da und ein „ping heise.de“ klappte auch. :-)

Erfolg

Danach die VM noch einmal neu im normalen Modus gestartet und der Installation-Assistent sah aus wie erwartet. Nun den Port 5015 in der Firewall im Cloud-Panel freigeschaltet, um die Installation abzuschließen. Ab hier lief dann alles wie es in der Anleitung von 3CX beschrieben war.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Durch die weitere Nutzung der Seite stimmst du der Verwendung von Cookies zu. Weitere Informationen

Die Cookie-Einstellungen auf dieser Website sind auf "Cookies zulassen" eingestellt, um das beste Surferlebnis zu ermöglichen. Wenn du diese Website ohne Änderung der Cookie-Einstellungen verwendest oder auf "Akzeptieren" klickst, erklärst du sich damit einverstanden.

Schließen